Raspberry Pi: Manchmal keine Ping-Antwort mit Edimax WLAN-Dongle

edimax wlanDa ich momentan etwas aktiver direkt auf einem meiner Raspberry’s in Python programmiere, bin ich auch regelmäßig per SSH aufgeschaltet.

Mein Raspberry ist per WLAN über einen Edimax EW-7811Un WLAN-Adapter an mein lokales LAN angeschlossen und von Zeit zu Zeit kommt es vor, dass z.B. die SSH-Verbindung vom Raspberry unterbrochen wird (due to software error) oder ich per SSH nach längerer Zeit nicht aufschalten kann – connection timeout.

In diesen Fällen setze ich einen Dauer-Ping auf den Raspberry und erhalte erstmal keine Antwort, obwohl z.B. meine Fritzbox der Meinung ist: Raspberry da und mit Internet verbunden. Etwa 10-30 Sekunden später kommt dann wieder eine Ping-Antwort durch.

Nach kurzer Recherche habe ich auch die Ursache gefunden: Der Edimax-WLAN-Adapter geht in einen Energiesparmodus! Grml…

Zum Glück lässt sich der Treiber entsprechend anpassen, um diesen Energiesparmodus zu deaktivieren. Dazu schaltet ihr euch per SSH auf euren Raspberry auf und editiert folgende Datei:

Diese füllt ihr mit folgender Zeile („i“ für insert drücken):

Schließt sie mit ESC + „:x“ + ENTER und startet den Raspberry neu.

Seither sind mir keine Probleme mehr aufgefallen – es scheint also tatsächlich eine permanente Lösung zu sein.

Bastian

Seit 2006 bin ich täglich im IT-Umfeld unterwegs und interessiere mich für technische Lösungen im Hard- und Softwarebereich, die einem den Alltag erleichtern. Zu meinen Hobbies zählt ein 3D-Drucker, das auch (handwerkliche) Tüfteln, Scripten sowie der unqualifizierte Umgang mit dem Lötkolben.

Das könnte Dich auch interessieren …

5 Antworten

  1. Alfred sagt:

    Genau das Problem mit dem Edimax hab ich seit einigen Tagen. Vielen Dank für diese Lösung

  2. Ralf sagt:

    Vielen Dank für diesen Beitrag. Bei mir lag exakt dieses Problem vor. Nach der Änderung läuft die Himbeere fehlerfrei :-)

  3. jensen sagt:

    was mach ich denn, wenn mir die .conf datei fehlt? habe den gleichen WLAN Stick.

    gruss,
    jens

  4. Wolfgang sagt:

    Hallo Bastian,

    danke für deinen Tipp. Habe lange im Internet gesucht und habe dann deinen Beitrag gefunden, der zur Lösung führte.

    Gruß,

    Wolfgang

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.